Erro ao instalar a gem mysql2 no Ubuntu

Já tive esse problema algumas vezes, essa gem deve ser meio bugada, e todas as vezes tenho que pesquisar para resolver, então resolvi deixar aqui para a posteridade.

No Ubuntu Linux basta instalar o pacote ‘libmysqlclient-dev’ com o comando:

sudo apt-get install libmysqlclient-dev

Depois disso é só instalar a gem normalmente e tudo vai correr bem, se aparecerem alguns erros referentes a RDoc e outras coisas relacionadas a documentação, não tem problema, ainda assim vai tudo funcionar.

Assim que precisar instalar em outro sistema operacional novamente coloco a solução aqui. 🙂

Anúncios